Back to overview
Downtime

Winter Storm Alert - Primary and Failover Networks Impacted

Feb 02 at 01:31pm CST
Affected services
Customer Portal
Ticketing System
Remote Monitoring & Management

Resolved
Feb 03 at 12:01pm CST

All issues have been resolved.

Created
Feb 02 at 01:31pm CST

Some of UniVista's internal support systems have been taken offline. Our datacenter's power and backup power systems remain functional, but multiple Internet connections to the facility have failed.